Установить только просмотр для всей формы кроме списка элементов

Простая готовая функция, которая может быть полезна в работе с формами.

Процедура УстановитьТолькоПросмотрЭлементовФормыКромеСписка(ЭлементыФормы,СтрСписокЧерезЗапятую="") Экспорт
   
_СтрСписокЧерезЗапятую = ","+СокрЛП(СтрСписокЧерезЗапятую)+",";
    Для Каждого
ЭлФормы Из ЭлементыФормы Цикл
        Если (
ТипЗнч(ЭлФормы)=Тип("Панель")) или
            (
ТипЗнч(ЭлФормы)=Тип("РамкаГруппы"))
        Тогда
            Продолжить;
        КонецЕсли;
        Если
Найти(_СтрСписокЧерезЗапятую,","+ЭлФормы.Имя+",")=0 Тогда
                Попытка
                   
ЭлФормы.ТолькоПросмотр = Истина;
                Исключение
                   
ЭлФормы.Доступность = Ложь;
                КонецПопытки
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Похожие материалы

Справочники

Документы

Отчеты

Обработки