Установить только просмотр для всей формы кроме списка элементов

Простая готовая функция, которая может быть полезна в работе с формами.

Процедура УстановитьТолькоПросмотрЭлементовФормыКромеСписка(ЭлементыФормы,СтрСписокЧерезЗапятую="") Экспорт
   
_СтрСписокЧерезЗапятую = ","+СокрЛП(СтрСписокЧерезЗапятую)+",";
    Для Каждого
ЭлФормы Из ЭлементыФормы Цикл
        Если (
ТипЗнч(ЭлФормы)=Тип("Панель")) или
            (
ТипЗнч(ЭлФормы)=Тип("РамкаГруппы"))
        Тогда
            Продолжить;
        КонецЕсли;
        Если
Найти(_СтрСписокЧерезЗапятую,","+ЭлФормы.Имя+",")=0 Тогда
                Попытка
                   
ЭлФормы.ТолькоПросмотр = Истина;
                Исключение
                   
ЭлФормы.Доступность = Ложь;
                КонецПопытки
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Ошибка

выдает ошибку
{Документ.МойДокумент.Форма.ФормаДокумента.Форма(78)}: Итератор для значения не определен
Для Каждого ЭлФормы Из ЭлементыФормы Цикл

Использую так

УстановитьТолькоПросмотрЭлементовФормыКромеСписка(ЭлементыФормы.ОтветственоеЛицоКонтрагента,"Организация");

пробовал и так

УстановитьТолькоПросмотрЭлементовФормыКромеСписка(ЭлементыФормы.ПанельОсновная,"");

что указывать в параметрах: ЭлементыФормы,СтрСписокЧерезЗапятую="" ?

Похожие материалы

Справочники

Документы

Отчеты

Обработки