Удаление пустых колонок в таблице значений.

Процедура УдалитьПустыеКолонкиТЗ(ТЗ)
   
МассивВозможноПустыхКолонок=Новый Массив;
    Для Каждого
ТекКолонка Из ТЗ.Колонки Цикл
       
МассивВозможноПустыхКолонок.Добавить(ТекКолонка.Имя);
    КонецЦикла;
    Для Каждого
СтрТЗ из ТЗ Цикл
       
КолВоВозможноПустыхКолонок=МассивВозможноПустыхКолонок.Количество();
        Для
К=1 по КолВоВозможноПустыхКолонок Цикл
            Если
ЗначениеЗаполнено(СтрТЗ[МассивВозможноПустыхКолонок[КолВоВозможноПустыхКолонок-К]]) Тогда
               
МассивВозможноПустыхКолонок.Удалить(КолВоВозможноПустыхКолонок-К);
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
   
КолВоВозможноПустыхКолонок=МассивВозможноПустыхКолонок.Количество();
    Для
К=0 по КолВоВозможноПустыхКолонок-1 Цикл
       
ТЗ.Колонки.Удалить(МассивВозможноПустыхКолонок[К]);
    КонецЦикла;
КонецПроцедуры

Похожие материалы

Справочники

Документы

Отчеты

Обработки