Определить что мы находимся в фоновом задании

Функция ЭтоФоновоеЗадание() Экспорт
   
НС=НомерСоединенияИнформационнойБазы();
   
мСоединения=ПолучитьСоединенияИнформационнойБазы();
    Если
мСоединения<>Неопределено Тогда
        Для Каждого
С Из мСоединения Цикл
            Если
С.НомерСоединения=НС Тогда
                Возврат
С.ИмяПриложения="BackgroundJob"
               
или С.ИмяПриложения="JobScheduler";
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
    Возврат Ложь;
КонецФункции

А зачем это?

Вот у нас периодически появляются неубиваемые фоновые задания.
После ядерного взрыва, когда передохли все крысы и тараканы, стоит запустить сервер 1С, там появляется это фоновое задание.
Можно ли им как-то управлять?
Регламентные задания стоят на ночь.
Чаще отрабатывают нормально, иногда подвисают.
Самое неприятное, что после перезагрузки 1С сервера, вдруг возникает фоновое задание ни с того, ни с сего.
Можно ли как-то отлаживать фоновые задания?

Отлаживать фоновые задания

Отлаживать фоновые задания конечно можно. Надо просто чтоб сервер приложений запускался с ключом -debug (это прописывается в реестре смотреть тут). И далее надо в меню Отладка->Подключение->кнопка "Автоматическое подключение" выключить галочку фоновое задание. После чего при запуске фонового задания например из консоли фоновых заданий можно выполнять отладку.

Похожие материалы

Справочники

Документы

Отчеты

Обработки