Универсальный обмен данными XML (выгрузка)

Обработку универсального обмена данными через XML можно использовать программно в своих целях, например для организации обмена между базами с различными конфигурациями.
Ниже приведем пример рабочего кода выполняющего выгрузку данных.

//Входные параметры:
//  ФайлПравилОбмена - файл с правилами
//  ДатаНачалаВыгрузки,ДатаКонцаВыгрузки - интервал выгрузки
//  ЧерезФайл - булево определяет выгружаем через файл или через COM
//  ИмяСервера,ИмяБазыДанных,ИмяПользователя,Пароль - параметры подключения к БД приемнику через COM
//  ИмяФайлаОбмена - имя файла обмена для выгрузки в файл
//  УзелПланаОбмена - узел плана обмена, если выгружаем объекты по плану обмена
//

Обработка=Обработки.УниверсальныйОбменДаннымиXML_2_0_28_1.Создать();
Обработка.РежимОбмена="Выгрузка";
Обработка.ИмяФайлаПравилОбмена=ФайлПравилОбмена;

Обработка.ЗагружатьДанныеВРежимеОбмена=Истина;
Обработка.ЗаписыватьРегистрыНаборамиЗаписей=Истина;
Обработка.ЗапоминатьЗагруженныеОбъекты=Истина;
Обработка.ИспользоватьОтборПоДатеДляВсехОбъектов=Истина;

Обработка.ДатаНачала=ДатаНачалаВыгрузки;
Обработка.ДатаОкончания=ДатаКонцаВыгрузки;

Обработка.ВыгружатьТолькоРазрешенные=Истина;

Если
ЧерезФайл Тогда
   
Обработка.ИмяФайлаОбмена = ИмяФайлаОбмена;
Иначе
   
Обработка.ВерсияПлатформыИнформационнойБазыДляПодключения="V81";
   
Обработка.ИмяСервераИнформационнойБазыДляПодключения=ИмяСервера;
   
Обработка.ИмяИнформационнойБазыНаСервереДляПодключения=ИмяБазыДанных;
   
Обработка.ПарольИнформационнойБазыДляПодключения=Пароль;
   
Обработка.ПользовательИнформационнойБазыДляПодключения=ИмяПользователя;
   
Обработка.ТипИнформационнойБазыДляПодключения=Ложь;
   
Обработка.АутентификацияWindowsИнформационнойБазыДляПодключения=Ложь;
   
Обработка.НепосредственноеЧтениеВИБПриемнике=Истина;
КонецЕсли;

Обработка.ТипУдаленияРегистрацииИзмененийДляУзловОбменаПослеВыгрузки=; // 0 - не снимать регистрацию,
                                                                        // 1 - снимать регистрацию

Обработка.ЗагрузитьПравилаОбмена();

//если выгружаем по плану обмена то нужен это блок
Для Каждого Стр Из Обработка.ТаблицаПравилВыгрузки.Строки Цикл
   
Стр.Включить=1;
    Для Каждого
Стр1 Из Стр.Строки Цикл
       
Стр1.Включить=1;
       
Стр1.СсылкаНаУзелОбмена=УзелПланаОбмена;
    КонецЦикла;
КонецЦикла;

Обработка.ВыполнитьВыгрузку();


Похожие материалы

Справочники

Документы

Отчеты

Обработки