Представление свойств и категорий в построителе отчетов

При доработке типового отчета, построенного на базе "Универсального отчета" слетают представления полей. Проиллюстрирую на скриншоте: примерпример С этой проблемой можно долго возиться, хотя исправляется она просто, поэтому опишу решение чтоб сэкономить ваше время.

//am+ сохраним представления доступных полей
СоотвИмяПредст = Новый Соответствие;
Для Каждого
ЭлДостПоля Из УниверсальныйОтчет.ПостроительОтчета.ДоступныеПоля Цикл
   
СоотвИмяПредст.Вставить(ЭлДостПоля.Имя, ЭлДостПоля.Представление);
КонецЦикла;
//am-

//то место когда мы подставляем патченый запрос
//и слетят представления доступных полей
УниверсальныйОтчет.ПостроительОтчета.Текст = ТекстЗапроса;

//am+ восстановим представления доступных полей
Для Каждого ЭлДостПоля Из УниверсальныйОтчет.ПостроительОтчета.ДоступныеПоля Цикл
   
ЭлДостПоля_Представление = СоотвИмяПредст.Получить(ЭлДостПоля.Имя);
    Если
ЭлДостПоля_Представление<>Неопределено Тогда
       
ЭлДостПоля.Представление = ЭлДостПоля_Представление;
    КонецЕсли;
КонецЦикла;
//am-

Всё оказалось очень просто.

Похожие материалы

Справочники

Документы

Отчеты

Обработки